Missing “Launch Script” function in Autoscript Application in Maximo / ICD 7.6

Have you ever noticed that starting with Maximo or ICD Version 7.6 the „Launch Script“ action is missing in the Automationscript Application? You might missing the following running person: Selection_042 If so you should read this post to solve this issue.

The new Maximo / ICD 7.6 still has all the functionality build in to run a script interactively. The only missing thing is a missing Signature Option “EXECUTE” in the automation Script application. To define this execute the following steps:

  1. Open Application Designer Application
    Goto > System Configuration > Plattform Configuration > Application Designer
  2. Search and open the “AUTOSCRIPT” application
  3. When you opened the “AUTOSCRIPT” application in Application Designer select from the “Select Action” Menü:
    “Add/Modify Signature Options”
  4. Click on “New Row” in the dialog
  5. Define a new Signature Option “EXECUTE” with a Description “Launch Script”
  6. Goto > Security > Security Groups and add the newly created signature option to the Automationscript application.

Now you only have to logoff and logon again to see the new action in the application script application. In Maximo I had to add the newly created signature option to a Security Group. Maybe you have to go this extra step too…

Hope this will help you to easily test Scripts!

One comment

  • I think you might need to add this to the showontoolbar system properties for this to show up.